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Templates: The Keys to Understanding MS Word 

What is a Template? 
A template is a blueprint that is used as the basis for creating other documents, such as 

• A fill-in form 

• A boilerplate shell for writing a standard operating procedure 

• A starting point for setting up technical documents (user guides, installation guides, 
operations manuals) 

Word uses templates as containers for styles, AutoText entries, fields, and macros. 

Key Points 
• You are always using templates—even when you create a blank document. 

• A document template is a special purpose template such as a memo or letter template. 

• A global template is a template containing settings that are used in all documents; 
examples are Normal.dot and templates that are known as add-ins. 

• For best results, install templates in the directory where Word looks for them: 
C:\Documents and Settings\<your user name>\Application Data\Microsoft\Templates 

Normal.dot (Main Global Template) 
• Normal.dot is Word’s base template. Word requires Normal.dot to function. If you 

delete Normal.dot and then open Word, Word will build a new copy of the template. 

• You can safely customize Normal.dot, but keep a backup copy with a different name. 

Global Templates as Add-Ins 
• Create a global add-in to run workgroup macros and provide access to AutoText that 

your workgroup frequently uses. 

• To run global add-ins every time you start Word, copy a global template to the following 
location:  

C:\Documents and Settings\<user name>\Application Data\Microsoft\Word\STARTUP 
If you store a template in the above location, you can use any custom features available 
in the template during the current Word session; these features are available as soon as 
Word opens. 

• To run global add-ins temporarily, select the Tools > Templates and Add-Ins menu 
command, then use the Add and Remove buttons to run templates in the background. 
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Document Templates 
• These are special purpose templates (for example, a template for creating an 

instructional module). 

• Document templates take precedence over global templates. If both types are currently 
running, and if both contain a Body Text style, Word will use the Body Text style from 
the document template, rather than the same style contained in the global template. 

• Store document templates on your hard drive so that Word will recognize any custom 
toolbars, menus, and other custom features that you have implemented. 

Finding or Changing the Default Directory for 
Document Templates 
The goal of the following procedure is to install your templates in Word’s default template 
directory. This procedure ensures that you can select the File > New command and see your 
custom templates in the New dialog box. 

1. Select the following menu command: Tools > Options. 

2. In the Options dialog box, click on the File Locations tab. 

3. In the File Types list, click on User Templates. 

4. Click the Modify button. In the Modify Location dialog box, you can either browse to a 
new path or simply note the path so that you know where to copy templates for future 
use. 

Figure 1.  Options Dialog Box 
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5. When you have finished verifying the path or changing the path, click OK to close the 
dialog box. 

6. Using Windows Explorer, copy and paste your template(s) to the specified path. 

Testing and Modifying Templates 
After you have stored a template in the default Templates directory on your hard drive, you 
can test and modify the template without opening the actual template. 

1. Select File > New. 

2. In the New template dialog box, double-click on one of the listed templates. A document 
based on the template (.doc file) opens. The new file is based on the template you 
selected. 

3. You can modify various template features in the following ways: 

o If you modify any template styles, click the Add to Template option in the Style 
dialog box. When you save or close the active document, Word will ask if you want 
to save the changes to the underlying template. 

o If you add or modify AutoText entries, make sure that the AutoText dialog box 
(Insert > AutoText) Look In list  points to the correct template. The default is All 
Active Templates, which will add the entry to all currently active templates if you 
do not select another listed template. 

o If you use the VBA editor to modify macros, locate your current template in the 
VBA Project Explorer. Select the template and then click on the Save button. 

Attaching Templates 
Use the Tools > Templates and Add-Ins dialog box to  

• attach a template to the current document so that the document inherits the styles and 
formatting used in the underlying template; 

• re-attach a document to its underlying template when the document has lost its 
connection and you can no longer see custom menus and toolbars stored in the template; 

• run global add-ins that are not stored in Word’s Startup directory. 
 

 
When attaching a template, you can check the Automatically update 
document styles check box to ensure that formatting in the current document 
matches the underlying template styles. Remember, however, that this change 
only works if the styles in the template and the document have the same name. 
After checking the Automatically update... check box, re-open the Templates 
and Add-Ins dialog box and uncheck the setting. You may not always want to 
update document styles, especially if you have modified the styles in the current 
document.  
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Styles: The Keys to Best Formatting Practices 
What is a Style? 
To understand Word styles, you need to understand the difference between direct and styled 
formatting: 

• Direct formatting is an approach to applying character or paragraph attributes using any 
of the following Format menu commands: 

Format > Font 
Format > Paragraph 
Format > Bullets and Numbering 
Format > Borders and Shading 

Casual Word users frequently apply direct formatting to selected text. This approach 
may be sufficient for short documents such as letters and memos, but it can become 
labor-intensive and problematic for users who routinely produce long documents. 

• Styled formatting is an approach to applying character or paragraph attributes using 
Word styles. A style is a set of formatting attributes that have been saved with a specific 
name and can be applied with one mouse click or keystroke. Styles are the best 
formatting approach to use, because they enable you to change formatting in one place 
and apply it globally. 

Key Points 
• You are always using styles. The Normal style is the default text used in blank 

documents. Don’t confuse the Normal style with the Normal template, Normal.dot. 
The Normal style is inside the Normal template. 

• A character style is used to format characters only (examples: Strong and Emphasis). 

• A paragraph style is used to format entire paragraphs (examples: Normal, Body Text, 
Headings 1-9). 

Methods for Applying Styles 
• The Style List, located on Word’s formatting toolbar (all versions of Word): 

Figure 2.  Style List 

 

• The Style dialog box, available by selecting Format > Style menu command  
(Word 97 and 2000) 

• The Styles and Formatting pane (Word XP and 2003) 
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Modifying a Style (Word 97 and 2000) 
Once you generate a document from a document template, you can modify the styles in the 
document without affecting the style counterparts in the underlying template (unless you 
choose to modify the underlying template style by selecting the Add to Template option). 

1. Place the cursor in a word or paragraph formatted in the style that you want to modify. 

2. Select the Format > Style menu command. 

3. In the Style dialog box, click Modify. 

4. Click Format. 

The resulting menu shows all of the same format commands available on Word’s Format 
menu. Using the same commands inside the Style dialog box ensures that you are now 
making global formatting changes, rather than changes to one location in the document. 

5. Change formatting as necessary. 

6. Click OK until you reach the main dialog box.  

7. Click Apply or Close. 

Modifying a Style (Word XP and 2003) 
1. Place the cursor in a word or paragraph formatted in the style that you want to modify. 

2. Select the Format > Styles and Formatting menu command. The current style appears 
at the top of the Styles and Formatting pane, labeled Formatting of selected text: 

Figure 3.  Styles and Formatting Pane 

 

3. In the dropdown list for the current style, click Modify. 

4. In the Modify Style dialog box, change formatting as necessary. 

5. Click OK until all dialog boxes are closed. 
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Figure 4.  Modify Style Dialog for Word XP and 2003 

 
 

Tips for Using Styles 
• When creating custom templates, use Word’s built-in styles as much as possible—

especially for applying numbering schemes. For example, for numbered steps in 
procedures, use the List Number style. For bulleted lists, use the List Bullet style. 

• Be aware that many Word styles are based on other styles. For example, a number of 
styles are based on the Normal style. If you change the font of the Normal style, all 
styles based on Normal will inherit the same font. You can prevent such cascading 
effects by setting a style’s Based on property to (no style). 

• When using styles, use direct formatting sparingly. If you want to include character 
formatting (bold or italics), use the Strong and Emphasis styles instead of the Bold and 
Italics buttons. The main direct attributes I use on top of styles are Format > Paragraph 
> (Keep with Next, Keep Lines Together). 

• If you inherit a document in which the author has applied direct formatting on top of 
styles, you can strip out the direct formatting using the following keystrokes: 

o Press Ctrl + Spacebar to remove directly applied character formatting. 

o Press Ctrl + Q to remove directly applied paragraph formatting. 

• Style names can contain spaces. Use spaces when naming custom styles, and give the 
style a name that enables users to understand the style’s purpose (for example, First 
Page Header). 

• To print a descriptive list of the styles that are stored in a document, select File > Print. 
In the Print dialog box, select Print What and select Styles from the dropdown list. 
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AutoText: The Key to Task Automation 
What is an AutoText Entry? 
AutoText entries are pre-defined text, graphics, table layouts, and other items that you can 
store in a template and instantly insert wherever you need them. AutoText reduces the tedium 
of repeatedly typing the same text. It also enables you to save time by setting up complex 
table and graphic formats, storing them in a template, and re-using them. 

Example: The following note was inserted into this document using an AutoText entry. The 
note was predefined and stored inside a template. 
 

 
<This note lines up with Body Text.>  

 

Key Points 
• AutoText entries can be stored only inside a template (.dot file)—not a document 

(.doc file). You cannot insert an AutoText entry in the current document unless the 
document is attached to the template in which the AutoText is stored. 

• To define AutoText entries, use the Insert > AutoText menu command. 

Defining an AutoText Entry 
1. Turn on Word’s formatting marks . 

2. Select the item you want to define as an AutoText entry.  

o If you want to include the text formatting, include the paragraph mark.  

o If you want the text to inherit the formatting of the paragraph in which it is inserted, 
select only the text and do not select the paragraph mark. 

3. Select Insert > AutoText > AutoText. 

4. In the AutoCorrect dialog box, ensure that the AutoText tab is displayed in the front of 
the tab group. 

5. In the Look in dropdown list, ensure that the correct template is shown. If not, select the 
template from the dropdown list. 

6. In the text box at the top of the dialog box, type a name for the new entry. 

7. Click Add. If you have previously added the same entry, Word will display a message 
asking whether you want to redefine the entry. Click Yes. 

8. Click OK. 
 

 
You can insert the new entry in the current document by selecting Insert > 
AutoText > AutoText and clicking on an entry in the menu list. Entries are 
organized by the style in which they were formatted. 
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Tips for Using AutoText Entries 
• You can sometimes insert an AutoText entry by typing part or all of its name. If Word 

recognizes the entry name, it displays pop-up text. When you see the pop-up text, press 
Enter to insert the associated entry. If Word has mistaken the entry for an entry with a 
similar name, ignore the pop-up and continue typing. 

• Word also includes an AutoText toolbar (View > Toolbars > AutoText). 

• The AutoText menu and toolbar lists vary according to the current cursor location. For 
example, if the cursor is in a table, only table-related entries will be visible.  
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Fields: The Keys to Dynamic Document Information 
What is a Field? 
A Word field is a placeholder for dynamic data. A field links to data that can be changed in 
one place and updated globally throughout a document. 

Key Points 
• Page numbers, dates, and cross-references are examples of fields. 

• Fields are best viewed with their gray shading turned on (Tools > Options > View > 
Show > Field Shading Always). 

• Fields can be toggled to show their underlying code or their results (displayed text). 

• If you insert a date by selecting Insert > Date and Time and choosing the 
Automatically Update option, you are inserting a field. 

• Fields can be locked and unlocked to manage document revision dates. 

• Most of Word’s built-in document properties have their own field types (for example, 
Title, Subject, and Category), which can be inserted into a document to display 
information. 

Inserting a Field (Word XP) 
Word’s document property fields are probably the best example of field usage. Try the 
following steps. 

1. Select File > Properties. 

2. In the <document name> Properties dialog box, select the Summary tab. 

3. In the Title text box, type a document title. 

4. Click OK. 

5. In the document body, place the cursor where you want to insert the document title. 

6. Select the Insert > Field menu command. 

7. In the Categories list on the left, select Document Information. 

8. In the Field names list, select DocProperty. 

9. In the Field properties list, select the Title property. 

10. Click OK. The document title appears as the field result. 
 

 
The Field dialog box in Word 2000 is somewhat different from the XP version of 
this feature. In the Word 2000 version, after selecting a field property you must 
click the Add to Field button to add the property value to the field.  
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Changing a Property Value and Updating the 
Corresponding Field 
1. Re-enter the <document name> Properties dialog box (File > Properties). 

2. Change the document title. 

3. Click OK. 

4. Locate the Title field that you inserted during the last procedure. 

5. Right-click on the field and select Update Field. The new title now shows. 
 

 
If you create Custom document properties (File > Properties > Custom), those 
properties will be included in the Field dialog box’s custom properties list. You 
can insert and update those property fields using the same technique used for 
fields related to built-in properties. 

 

Tips for Using Fields 
• When you open a document that includes fields, the fields automatically update. 

• Word includes a printing option to update fields when a document is printed. If you want 
to turn off this option, select File > Print > Options > Printing Options and uncheck 
Field Codes. 

• To update all fields in a document, select all text in the document (Ctrl + A or Edit > 
Select All) and press F9. Since this method doesn’t update fields stored in document 
headers and footers, switch the document view from Print Layout to Normal and back to 
Print Layout. This method usually updates the Header and Footer fields, although I 
usually write macros to ensure that the fields update. 

• To toggle a field and display its codes, right-click on the field and choose Toggle Field 
Codes, or select the field and press Shift + F9. Perform this step again to show the field 
results. 

• Fields can be locked to prevent updating. For example, you may want to use date fields, 
but you may not always want them to update. To lock a field, select the field and press 
Ctrl + F11. To unlock the field, select it and press Ctrl  + Shift + F11. To test a field 
and determine whether it is locked, right-click on the field. If the field is locked, the 
shortcut menu’s Update Field command will be disabled. 

• Word includes Sequence fields, which are great for list numbering that is independent of 
Word’s internal list templates. Sequence fields are similar to FrameMaker’s building 
blocks for numbering. 
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Customization:  
The Key to Making Word Work the Way You Do 
In addition to using the features described in the previous sections, you can add macros, 
custom menus, and custom toolbars to Word templates. 

Macros 
Macros are scripts created in the Visual Basic for Applications (VBA) programming 
language. You can use Word’s macro recorder (Tools > Macro > Record New Macro) to 
record simple macros, or you can use the VBA editor (Tools > Macro > Visual Basic 
Editor) to write more extensive macros. 

An effective way to learn VBA is to record macros, switch to the VBA editor, and examine 
the resulting code. If you know Word’s advanced features, the code will be easier to read. 
 

 
Macros are beyond the scope of today’s discussion, but I can recommend 
resource books. 

 

Custom Menus 
Adding a Custom Menu 
1. Select View > Toolbars > Customize. 

2. In the Customize dialog box, select the Commands tab. 

3. At the bottom of the dialog box, ensure that the correct template shows in the Save in 
field. If not, click the dropdown list and choose the correct template. 

 

Always verify that you are about to customize the correct template. Word 
often displays the Normal.dot template as the default in many lists, so you 
could easily customize Normal without intending to. You should only add 
customized features to the Normal template if you want those features to be 
available in all of your documents. 

 
4. Scroll to the bottom of the Categories list and select New Menu. New Menu now 

appears in the Commands list on the right. 

5. Click and drag the new menu command on the right to Word’s Menu Bar.  

6. Drop the menu wherever you want to position it. 

7. Click on various categories on the left and examine the Commands list for each 
category. 

8. Drag your preferred commands and drop them on the new menu. 

9. Click Close. 
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Custom Toolbars 
Adding a Custom Toolbar 
1. Select View > Toolbars > Customize. 

2. In the Customize dialog box, select the Toolbars tab. 

3. Click New. 

4. In the New Toolbar dialog box, name the toolbar and ensure that the correct template 
shows in the Make toolbar available to field. If not, click the dropdown list and choose 
the correct template. 

5. Click OK. A small floating toolbar appears. The toolbar will become larger as you add 
buttons. 

6. Click on various categories on the left and examine the Commands list for each 
category. 

7. Drag your preferred commands and drop them on the new toolbar. 

8. Right-click on one of the new toolbar buttons and experiment with the shortcut menu 
commands. 

9. When you have finished, click Close. 

 
 

References 

Books 
Bott, E., and Leonhard, W. Special Edition Using Microsoft Office XP. Indianapolis, IN. 

Que Publishing, 2001. 

Hart-Davis, G.  Word 2000 Developer’s Handbook.  Alameda, CA.  SYBEX, Inc., 1999. 

Payne Consulting Group, Inc.  Word 2002 for Law Firms.  Roseville, CA.  
Prima Publishing, 2001. 

Roman, S. Writing Word Macros. Sebastopol, CA. O’Reilly & Associates, 1999. 

Web Sites 
Word MVP FAQ Site at http://word.mvps.org/ 

Woody’s Office Watch (free newsletter) – subscribe at http://www.woodyswatch.com/office/ 

 

 

http://word.mvps.org/
http://www.woodyswatch.com/office/

	Templates: The Keys to Understanding MS Word
	What is a Template?
	Key Points
	Normal.dot (Main Global Template)
	Global Templates as Add-Ins
	Document Templates
	Finding or Changing the Default Directory for Doc
	Testing and Modifying Templates
	Attaching Templates
	What is a Style?
	Key Points
	Methods for Applying Styles
	Modifying a Style (Word XP and 2003)
	Tips for Using Styles
	What is an AutoText Entry?
	Key Points
	Defining an AutoText Entry
	Tips for Using AutoText Entries
	What is a Field?
	Key Points
	Inserting a Field (Word XP)
	Tips for Using Fields
	Macros
	Custom Menus
	Adding a Custom Menu
	Adding a Custom Toolbar


	References
	Books
	Web Sites


